Q1:均价线上穿大盘分时叠加线选股预警公式:通达信用,均价线与大盘分时叠加线金叉选股预警公式。

个股的均价线上穿此线后一般说来当天此股是强于大盘的回抽均价线后再次量价齐升突破前高都会有好的收益
------------------------------------------------------------------
谢谢分享你的经验,你真是目前还活着的雷锋

Q2:分时追涨公式

四个分时指标公式:
★分时雄起!分时走势上部主图专用!
ma5:ma(c,5);
ma10:ma(c,10);
ma20:ma(c,20);
ma30:ma(c,30);
ma60:ma(c,60);
ma120:ma(c,120);
fa:=barslast(cross(ma10,ma5)) and cross(ma5,ma10);
fb:=fa and ma5>ma30 and ma10>ma30 and ma10>ref(ma10,1);
STICKLINE(fb,l,l-0.09,4,0),COLORYELLOW;
DRAWTEXT(fb,l-0.13,'雄起'),COLORYELLOW;
fa2:=barslast(cross(ma60,ma20)) and cross(ma20,ma60);
fb2:=fa2 and ma20>ma120 and ma60>ma120 and ma20>ref(ma20,1);
STICKLINE(fb2,l,l-0.09,4,0),COLORYELLOW;
DRAWTEXT(fb2,l-0.13,'雄起'),COLORYELLOW;
★实战分时!下部专用!可做进一步简化处理!
input:LONG(26,1,100),SHORT(12,1,100),M(9,1,100),p1(19,1,100),p2(120,1,250);
DIF:EMA(CLOSE,SHORT) - EMA(CLOSE,LONG);
DEA:=EMA(DIF,M);
MACD:=2*(DIF-DEA);
MACD2:2*(DEA-DIF),COLORFF89B2,DOTLINE;
MA5:=MA(CLOSE,5);
MA10:=MA(CLOSE,10);
MA30:=MA(CLOSE,30);
MA60:=MA(CLOSE,60);
MA65:=MA(CLOSE,65);
MA250:=MA(CLOSE,250);
突破线:=MIN(MA60*1.1,MA250*1.3);
差幅:=C/MIN(MA60*1.1,MA250*1.3)-1;
均线流:=(MA5>MA65 AND MA10>MA65 AND MA30>MA65 AND MA5<MA30)*0.3;
PL1:=(CLOSE - MA60) / MA60 < 0.1;
PL2:=(CLOSE - MA250) / MA250 < 0.3;
偏离率:(PL1 = 1 AND PL2 = 1) * 0.2,STICK,COLORFF00FF,LINETHICK2;
MACD超跌:=COUNT((DIF<DEA),10)=10;
MACD1:MACD超跌 * "MACD.MACD"(LONG,SHORT,M)*(-1),COLOR009900,LINETHICK2;
目标:IF(均线流=0.3 AND MACD超跌 AND 偏离率=0.2 ,0.8,0),COLOR7070FF,LINETHICK2;
MBSJ:=BARSLAST(目标 = 0.8);
放量上涨:=V/REF(V,1) >= 1.1 AND C/REF(C,1) >= 1.01;
SZSJ:=BARSLAST(放量上涨 = 1);
MACD雄起:=CROSS(DIF,DEA);
JCSJ:=BARSLAST(MACD雄起 = 1);
关注:(MACD雄起 AND REF(MACD1,1) < 0)*-0.1,COLOR00FF00;
启动:(MBSJ <= 20 AND SZSJ <= 1 AND JCSJ <= 1) * 1,COLORFFFF00,LINETHICK2;
突破:(偏离率 = 0 AND REF(COUNT(偏离率 = 0.2,10) = 10,1) = 1) * -0.1,COLORRED;
STICKLINE(偏离率 = 0.2,0,0.2,1,0),colorFF00FF;
DRAWTEXT(关注=-0.1,-0.01,'关●注'),color00ff00;
DRAWTEXT(启动,0.8,'★买'),colorFFFF00;
DRAWTEXT(突破=-0.1,-0.01,'突●破'),colorred;
N15HIGH:=REF(HIGH,15);
N1LOW:=REF(LOW,1);
FF:=(((N15HIGH - N1LOW) / N1LOW) > 0.15);
DRAWICON((((((CROSS(MA(CLOSE,P1),MA(CLOSE,P2)) > 0) AND (((N15HIGH - N1LOW) / N1LOW) <
0.15)) AND (OPEN >= MA(CLOSE,P1))) AND (CLOSE >= MA(CLOSE,P1))) AND (LOW <= MA
(CLOSE,P1))),0.5,1);
DRAWTEXT((((((CROSS(MA(CLOSE,P1),MA(CLOSE,P2)) > 0) AND (((N15HIGH - N1LOW) / N1LOW) <
0.15)) AND (OPEN >= MA(CLOSE,P1))) AND (CLOSE >= MA(CLOSE,P1))) AND (LOW <= MA
(CLOSE,P1))),0.5,'★^回头望月'),color0099CC;
低位雄起:CROSS(DIF,DEA) AND DIF<-0.1,colorwhite;
STICKLINE(低位雄起,0,0.08,6,0),COLORwhite;
DRAWTEXT(低位雄起,低位雄起-1.5,' 低位雄起'),COLORWHITE;
JCCOUNT:=COUNT(CROSS(DIF,DEA),BARSLAST(DEA>=0));
雄起:CROSS(DIF,DEA) AND DEA<0 AND COUNT(JCCOUNT=2,21)=1,coloryellow;
STICKLINE(雄起,0,0.06,6,0),ColorFF00FF;
DRAWICON(雄起,dea*1.04,1) ;
DRAWTEXT(雄起,0.5,' 雄起'),ColorYELLOW;
if(dif<0,dif,0),coloryellow,linethick2;
if(dif<0,0,dif),colorred,linethick2;
if(dif<dea,dif,dea),COLORWHITE,linethick2;
if(dif>dea,dea,dea),COLORFF9933{colorff00ff},linethick2;
操盘:STICKLINE(MACD>=0 AND MACD>=REF(MACD,1),0,MACD,4,1),COLORRED{COLOR6058FF};
减仓:STICKLINE(MACD>=0 AND MACD< REF(MACD,1),0,MACD,4,0),COLORblue{COLOR6058FF};
反弹:STICKLINE(MACD<0 AND MACD>=REF(MACD,1),0,MACD,4,1),COLORYELLOW{COLORFFFF00};
寻底:STICKLINE(MACD<0 AND MACD< REF(MACD,1),0,MACD,4,0),COLORFFFF00;
空仓:0,COLORWHITE;
★分时机密!下部专用!可做进一步简化处理!多用于开盘就抓涨!
V1:=(C*2+H+L)/4*10;
V2:=EMA(V1,13)-EMA(V1,34);
V3:=EMA(V2,5);
V4:=2*(V2-V3)*5.5;
庄秘撤: IF(V4<=0,V4,0),COLOR00FF00,LINETHICK2;
庄秘进: IF(V4>=0,V4,0),COLORFF00FF,LINETHICK2;
V5:=(HHV(INDEXH,8)-INDEXC)/(HHV(INDEXH,8)-LLV(INDEXL,8))*8;
V6:=EMA(3*V5-2*SMA(V5,18,1),5);
V7:=(INDEXC-LLV(INDEXL,8))/(HHV(INDEXH,8)-LLV(INDEXL,8))*10;
V8:=(INDEXC*2+INDEXH+INDEXL)/4;
V9:=EMA(V8,13)-EMA(V8,34);
VA:=EMA(V9,3);
VB:=(V9-VA)/2;
大筹金进场: IF(VB>=0,VB,0),COLORYELLOW,LINETHICK2;
大筹金撤走: IF(VB<=0,VB,0),COLORBLUE,LINETHICK2;
aa:=WINNER(CLOSE+CLOSE*15/100)*100;
bb:=WINNER(CLOSE+CLOSE*0/100)*100;
cc:=aa-bb;
dd:=(WINNER(CLOSE-CLOSE*0.1/100)-WINNER(CLOSE-CLOSE*15/100))*100;
ee:=cc<3 and dd<0.5 and OPEN<>LOW;
a1:=DYNAINFO(6);
a2:=IF(LOW>a1,0,IF(HIGH<a1,1,(a1-LOW+0.01)/(HIGH-LOW+0.01)));
a3:=VOL/WINNER(LOW);
a4:=REF(HHV(CLOSE,120),1);
a5:=REF(LLV(CLOSE,120),1);
a6:=100*(CLOSE-a5)/(a4-a5);
a7:=a2>0 or a2=1;
a8:=a7 and a3/REF(a3,3)>=3 and a6<80;
a9:=REF(a8,1) or REF(a8,2) or REF(a8,3) or REF(a8,4);
a10:=a8 and a9;
a11:=IF(FILTER(a8,3),5,0);
a12:=IF(FILTER(a10,3) or ee,10,0);
筹码进场日:IF(a11,8,0),LINETHICK0;
STICKLINE(a12,0,15,5,0),colorff00ff;
筹码加仓日:IF(a12,88,0),LINETHICK0;
STICKLINE(a12,0,15,5,0),colorff00ff;
STICKLINE(a11,0,5,5,0),colorff7700;
STICKLINE(a11,0,5,4.5,0),colorff8800;
STICKLINE(a11,0,5,4,0),colorff9900;
STICKLINE(a11,0,5,3.5,0),colorffaa00;
STICKLINE(a11,0,5,3,0),colorffbb00;
STICKLINE(a11,0,5,2.5,0),colorffcc00;
STICKLINE(a11,0,5,2,0),colorffdd00;
STICKLINE(a11,0,5,1,0),colorffee00;
STICKLINE(a12,0,15,4.5,0),color102099;
STICKLINE(a12,0,15,4,0),color1020aa;
STICKLINE(a12,0,15,3.5,0),color1020bb;
STICKLINE(a12,0,15,3,0),color1020cc;
STICKLINE(a12,0,15,2.5,0),color1020dd;
STICKLINE(a12,0,15,2,0),color1020ee;
STICKLINE(a12,0,15,1,0),color1020ff;
DRAWTEXT(a11,8,'筹码进场');
DRAWTEXT(a12,17,'筹码加仓');
Var1:=REF(LOW,1);
Var2:=SMA(ABS(LOW-Var1),13,1)/SMA(MAX(LOW-Var1,0),13,1)*4;
Var3:=EMA(Var2,13);
Var4:=LLV(LOW,34);
Var5:=EMA(IF(LOW<=Var4,Var3,0),3);
主力进场:
STICKLINE(Var5>REF(Var5,1),0,Var5,7,0 ),COLORRED;
洗盘:IF(VAR5<REF(VAR5,1),VAR5,0),COLORGREEN,LINETHICK2;
STICKLINE(VAR5<REF(VAR5,1),0,VAR5,2,1),COLORGREEN;
Var6:=100-3*SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA((CLOSE-
LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);
Var7:=100-3*SMA((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA((OPEN-LLV
(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);
Var8:=Var6<REF(Var7,1) AND VOL>REF(VOL,1) AND CLOSE>REF(CLOSE,1);
DRAWTEXT(Var8 AND COUNT(Var8,30)=1,40,'★注意有筹码进场迹象');
★分时作为!(专门监视庄家行动变化)同时也可用于买入信号观注点!
Var1:=EMA(EMA(CLOSE,13),13);
作为:=(Var1-REF(Var1,1))/REF(Var1,1)*1000;
无庄作为:STICKLINE(作为<0,作为,0,4,0),colorwhite;
有庄作为:STICKLINE(作为>REF(作为,1) AND 作为>0,作为,0,4,1),colorred;
Var2:=100*WINNER(CLOSE*0.95);
出货作为:STICKLINE(作为<REF(作为,1) AND 作为>0,作为,0,4,0),color00ff00;
高度作为:STICKLINE(Var2>50 AND COST(85)<CLOSE AND 作为>0,作为,0,4,0),colorff00ff;
a10:=CROSS(作为,0);
开始作为:if(a10,6,0),coloryellow;
★分时实战
input:LONG(24,1,100),SHORT(13,1,100),M(6,1,100),N(6,1,100);
MA5:=MA(CLOSE,5);
MA10:=MA(CLOSE,10);
MA20:=MA(CLOSE,20);
MA30:=MA(CLOSE,30);
DIF:EMA(CLOSE,SHORT) - EMA(CLOSE,LONG);
DEA:EMA(DIF,M);
MACD:=2*(DIF-DEA);
Q:2*(DEA-DIF),COLORFF9933;
MACD超跌:=COUNT((DIF<DEA),10)=10;
Q1:MACD超跌 * "MACD.MACD"(LONG,SHORT,M),COLORFF00FF,LINETHICK2;
{本行中,大智慧版本选择*(-1);飞弧版本选择*(1)}
MACD金叉:=CROSS(DIF,DEA);
DTPL:=MA10>MA30 AND MA20>MA30 AND MA30>REF(MA30,1);
关注:=(MACD金叉 AND REF(Q1,1) < 0)*-0.1;
均线:(DTPL AND MA5>MA30 AND MA5<MA10)*-0.15,colorFF89B2,LINETHICK1,PRECIS2,DOTLINE;
偏离:(C<MIN(MA20*1.05,MA30*1.1) AND C>MA30)*0.15,COLOR009900,LINETHICK1,PRECIS2,DOTLINE;
DRAWTEXT(关注,-0.15,'GZ'),color00ff00,align1;
BDGD:=C=HHV(C,20);
GDSJ:=BARSLAST(BDGD);
目标:IF(均线 AND 偏离 AND GDSJ>=N,0.5,0),COLORffff00,POINTDOT,PRECIS1,LINETHICK3;
MBSJ:=BARSLAST(目标);
MAV5:=EMA(V,5);
MAV10:=EMA(V,10);
LNMACD:=((V-MAV5)/MAV5*2+(V-MAV10)/MAV10)*10;
量坑:=LNMACD<=-10;
优选:=目标 AND COUNT(量坑,3)>=1;
DRAWICON(优选,-0.2,12);
N15HIGH:=REF(HIGH,6);
N1LOW:=REF(LOW,1);
DRAWTEXT((((((CROSS(MA(CLOSE,13),MA(CLOSE,24)) > 0) AND (((N15HIGH - N1LOW) / N1LOW) <
0.15)) AND (OPEN >= MA(CLOSE,13))) AND (CLOSE >= MA(CLOSE,13))) AND (LOW <= MA
(CLOSE,13))),0.5,'^回头望月'),color0099CC;
低位金叉:=CROSS(DIF,DEA) AND DIF<-0.1;
STICKLINE(低位金叉,0,0.26,6,1),COLORwhite;
DRAWTEXT(低位金叉,低位金叉-1.3,' 低金'),COLORWHITE;
JCCOUNT:=COUNT(CROSS(DIF,DEA),BARSLAST(DEA>=0));
二次金叉:=CROSS(DIF,DEA) AND DEA<0 AND COUNT(JCCOUNT=2,21)=1;
STICKLINE(二次金叉,0,0.2,4,0),ColorFF00FF;
DRAWTEXT(二次金叉,0.4,' 二金'),ColorYELLOW;
A4:=BARSLAST(ref(cross(dif,dea),1));
B1:=ref(c,A4+1)>c and ref(dif,A4+1)<dif and cross(dif,dea);
DRAWTEXT(FILTER(B1>0,5),dif+0.2,'背离'),COLORyellow;
STICKLINE(MACD>=0 AND MACD>=REF(MACD,1),0,MACD,3,0),COLORRED{COLOR6058FF};
STICKLINE(MACD>=0 AND MACD< REF(MACD,1),0,MACD,3,0),COLORblue{COLOR6058FF};
STICKLINE(MACD<0 AND MACD>=REF(MACD,1),0,MACD,3,0),COLOR4ABEFF{COLORFFFF00};
STICKLINE(MACD<0 AND MACD< REF(MACD,1),0,MACD,3,0),COLORFFFF00;
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
周K:=MA(".K#WEEK"(9,3,3) ,5);
周D:=MA(".D#WEEK"(9,3,3) ,5);
周J:=MA(".J#WEEK"(9,3,3) ,5);
DRAWICON(k<20 and cross(k,d),MACD,1),align2;
周金RAWTEXT(CROSS(".K#WEEK"(9,3,3),".D#WEEK"(9,3,3)) ,MACD,'▲'),align2,COLORred;
周死RAWTEXT(CROSS(".d#WEEK"(9,3,3),".k#WEEK"(9,3,3))
,macd*1.5,'▼'),align2,COLORgreen;
月金RAWTEXT(CROSS(".K#MONTH"(9,3,3),".D#MONTH"(9,3,3))
,MACD,'▲'),align2,COLORMAGENTA;
月死:DRAWTEXT(CROSS(".D#MONTH"(9,3,3),".K#MONTH"(9,3,3))
,macd*1.5,'▼'),align2,COLOR3fbb8b;
if(dif<0,dif,0),coloryellow,linethick2;
if(dif<0,0,dif),colorred,linethick2;
if(dif<dea,dif,dea),COLORWHITE,linethick2;
if(dif>dea,dea,dea),COLORgreen{colorff00ff},linethick2;
HH:=MA(CLOSE,10);
GG:=MA(CLOSE,12);
上:=ema((MA(HIGH,3) * 1.05),30);
下:=ema((MA(LOW,3) * 0.96),30);
决战:STICKLINE((((CROSS(DIF,DEA) AND ((下 - REF(下,1)) > 0)) AND (MACD >= REF(MACD,1))) AND
(DIF < 0)),DIF,0.3,1,0),color0000FF;
{DRAWICON((((CROSS(DIF,DEA) AND ((下 - REF(下,1)) > 0)) AND (MACD >= REF(MACD,1))) AND (DIF
< 0)),0.4,0);}
DRAWTEXT((((CROSS(DIF,DEA) AND ((下 - REF(下,1)) > 0)) AND (MACD >= REF(MACD,1))) AND (DIF
<= 0)),0.3,'DIF金叉'),color0000FF;
STICKLINE(FILTER(((((MACD >= REF(MACD,5)) AND ((下 - REF(下,1)) > 0)) AND (MACD <= 0)) AND
((GG - REF(GG,1)) >= 0)),3),0,0.4,1,0),color00FF00;
{DRAWICON(FILTER(((((MACD >= REF(MACD,5)) AND ((下 - REF(下,1)) > 0)) AND (MACD <= 0)) AND
((GG - REF(GG,1)) >= 0)),3),0.5,0);}
DRAWTEXT(FILTER(((((MACD >= REF(MACD,5)) AND ((下 - REF(下,1)) > 0)) AND (MACD <= 0)) AND
((GG - REF(GG,1)) >= 0)),3),0.4,'绝佳买入'),color00FF00;

Q3:求高手帮编写个通达信分时在均价线上运行的选股公式.

分时线:MA(CLOSE,1);
均价:SUM(V*C,0)/SUM(V,0),COLORGREEN,LINETHICK2;
T1:=分时线<均价;
CC:=REF(T1,1);
N分钟内:BARSLAST(T1),NODRAW;

Q4:均价线选股:通达信用均价线与大盘分时叠加线金叉选股预警公式

两个公式源码要出来

Q5:谁知道大智慧里三线金叉的选股公式

好象是没有公式的吧,只能是看MACD,主力线,KDJ线同时向上的股应该可以做

Q6:macd低位三次金叉选股公式通达信

DIFF:=EMA(CLOSE,12)-EMA(CLOSE,27);DEA:=EMA(DIFF,9);
MACD:=2*(DIFF-DEA);
JCCOUNT:=COUNT(CROSS(DIFF,DEA),BARSLAST(DEA>=0));
三次金叉:CROSS(DIFF,DEA) AND DEA<0 AND COUNT(JCCOUNT=3,21)=1;